Skip to content

Toggle service links

How to make hyperlinks in your documents

Page 1 of 2

This article explains how to use links in your word processor to help you find connected documents and text.

You can harness the power of hyperlinks in your note taking and essay writing very easily, boosting your productivity.

How links work

Hyperlinks provide a familiar way of finding web pages, but you may be less familiar with using links to other files on your computer, or specific places in documents. For example, when you take notes in a word processing document you can include a link to the relevant page in your module material, or to a paragraph of related material in another of your notes files. This can save you a lot of time later, especially during revision.

A hyperlink has two parts.

  • The first is the text that displays on the page, often styled in blue with an underline.
  • The web address link itself – the destination to which a clicker is taken.

Sometimes the two are the same, with the web address link also being the visible text – https://learn1.open.ac.uk/course/view.php?id=100132. Sometimes they’re different – the OU Computing Guide. Both of those links take you to the same place, but one is much easier for a reader to understand in advance.

Whichever word processor you use, when you insert a hyperlink into your document you'll need to provide the web address and decide on the text you want to display. It makes sense to use something meaningful for the display text. You can, if you wish, attach a link to a picture or other graphic object, instead of text, but there’s no equivalent of underlined blue type to remind you that the link is there.

How to make links

  • In the case of a web page you should include the complete address that usually, though not always, starts with 'http://' or 'https://'. You should copy the address from the address window in your web browser because if you type it and get even a single character wrong the link won’t work. If the web page is subsequently moved you might be lucky and find that the webserver silently directs you to the new location.
  • Where you're making a link to another file in your computer or another place in your document you need to take some care as, if you subsequently move the file you link will certainly fail. So it’s important that you have an organised filing structure, as recommended in the article How to organise your computer files. That will reduce the chance of you moving files around.

Making a link to your own document

To link to a specific place in a document you first have to give that place a name, which could be the name of a heading or a 'bookmark' that you insert.

  • If you use styles properly in your word processor, as recommended in the article on styles , you can link directly to any heading within the document you have open.
  • If you want to link to a specific place in another document (the 'target' document) some word processors can’t use the headings and instead have to use bookmarks.

A word processor bookmark makes an invisible mark at a point in the text that can then be accessed by the word processor and other program. It's given a name that acts as an address for links from inside or outside the document.

Microsoft Word for Windows

Word for Windows logo

Word and all Microsoft Office programs (and many others from other manufacturers) use the command Ctrl-K (Cmd-K on a Mac) to make a hyperlink. If you prefer, you can select the Insert tab and click on the Hyperlink button in the Links section.

To make a hyperlink to a web page, copy its address from the address window of your browser. Then go to the point in the word processing file where you want the link to appear.

This is where you choose whether the link is going to be attached to other text or is to appear as itself. If you’re going to attach it to some existing text, select that text now.

Do Ctrl-K to open the hyperlink box. Confirm that the ‘Link to’ setting on the left is ‘Existing File or Web Page’ (the default) then Ctrl-V to paste the copied address into the field marked Address which is selected by default.

Screenshot of Word 2013 hyperlink dialog box

If you had text selected you’ll see that it’s been inserted into the Text to display box (if not, the web address that you pasted into the lower box also shows in the upper box). You also have the option to click on the ScreenTip button and enter text that will show in a balloon when you hover over the link. You might find this useful to say more about what the link is — which might be useful at revision time. Then hit return. The link appears in dark blue type with an underline.

To link to a heading in the document you have open, select Place in This Document in the left-hand column of the hyperlink box. All the styled headings and bookmarks in the document are offered as objects to link to.

To make a link to a bookmark in another document or file, you must first make the bookmark. To do this, open the target file and find the point you want to link to. Do Shift-Ctrl-F5 or click the Bookmark button on the Insert menu.

Then type a name for the bookmark. You’re not allowed space characters in the name, so you could separate words with underscores_like_this. Then click Add and save the file. If you know you’re going to link to a file you could bookmark the major headings as you write them.

Then, back in the original document click where you want the link to appear. Type Ctrl-K, check the ‘Link to’ setting is Existing File or Web Page but this time browse for the file by clicking on the folder icon.

Folder icon

Find and select the file you want to link to. Its path (or file address) will appear in the Address box. If you just want to find the file quickly when you click on the link that’s all you have to do but we'll take another step here and go to a specific place in that file.

Click the button marked ‘Bookmark…’ and the bookmarks in the target file will be offered to you. Locate the one you want and select it. Click OK and test the link by using Ctrl-Click. You should be taken directly to the place you bookmarked.

The procedure on the Mac is essentially the same but the dialog box looks different and the terminology differs somewhat.

OpenOffice and LibreOffice

Apache OpenOffice logoLibreOffice logo

The two open-source office suites are currently identical in respect of adding hyperlinks.

To make a hyperlink to a web page, copy its address from the address window of your browser. Then go to the point in your document where you want the link to appear.

This is where you choose whether the link is going to be attached to other text or is to appear as itself. If you’re going to attach it to some text, select that text now.

Do Alt-I-H (ie hold down Alt as you type the letter i then h, or go to Insert > Hyperlink to open the hyperlink box. Confirm that the Internet button in the left column is selected then Ctrl-V (Cmd-V on a Mac) to paste the copied address into the field marked Address which is selected by default.

If you had text selected you’ll see that it’s been inserted into the Text field. Hit Apply, then the red X at the top right to dismiss the dialog box. The link appears in dark blue type with an underline.

Screenshot of LibreOffice hyperlink dialog box

To make a link to a place in another file you must have both files open together with the Navigator. Hit F5 or go to View > Navigator. OpenOffice and LibreOffice have an advantage over Microsoft Office in that they can link to headings in another document, not just bookmarks, so long as you've used the built-in styles labelled Heading1 through to Heading10 – see the article on Styles, outlines, tables of contents and templates.

Screenshot of LibreOffice Navigator dialog showing how to link to another open document

The Navigator shows a list of objects in the currently active document. But you want to link to a position in another document, so go to the dropdown at the bottom of the Navigator and select the target document which will be marked ‘(inactive)’ – the document has to be open already for it to show up in this list.

The list in the navigator now shows the objects in the inactive document. In order to link to any of those objects you first click on the plus sign next to the icon (in this case Headings) to reveal the available objects. Then you drag and drop the heading name to the place in the active document’s text that you want the link. The link is made automatically. You can edit the heading name once the link is made to make it shorter or maybe to make it longer with information about which file it has come from.

If for any reason you can’t link to a heading you still have the option of linking to a bookmark. First you make the bookmark. To do this, open the target file and find the point you want to link. Do Alt-I-K (ie hold down Alt as you type the letter i then k) or go to Insert > Bookmark.

Then type a name for the bookmark and click Apply. You can use spaces in the name but some other characters are reserved and automatically removed if you type them. Save the file but keep it open.

Go back to the source document, open the Navigator (F5, or View > Navigator). Proceed as for the Heading link, selecting the inactive file from the dropdown, but this time click the plus sign next to Bookmarks instead of Headings. Drag and drop the bookmark’s name to the place where you want the link to sit.

Google Docs

Google Docs logo

Google Docs are very easy to link from and link to because they only live on the web.

To make a hyperlink to a web page, copy its address from the address window of your browser. Then go to the point in the Google Doc, also in your browser, where you want the link to appear.

This is where you choose whether the link is going to be attached to other text or is to appear as itself. If you’re going to attach it to some text, select that text now.

Type Ctrl-K (Cmd-K on a Mac) or click on the link button that looks like three links of a chain.

Google link icon

Paste the address into the Link field. If you had text selected you’ll see that it’s been inserted into the Text field. Leave it blank if you want the web address to be the visible link. Then click Apply. The link appears in dark blue type with an underline.

One useful feature of the Link dialog is that it can also act as a search box to look for the page you need to link to if you don’t already have the address to hand.

To follow a link while you’re editing the document you have to position the cursor by clicking in the link and then type Alt-Enter or Alt-Return.

If you use the built-in styles for headings you can easily link to them in the currently open document. When the Link dialog box opens in a document where headings have been used you’ll see the word ‘Headings’ with a disclosure triangle next to it. Click on the triangle and all the available headings are shown so you can select the one you want.

Because the files all live on the web they each have a web address. So linking to another Google Doc uses exactly the same process. Open the target Doc and copy its web address to paste into the Link field.

Linking to a heading in another Doc is very simple too. When you click in a heading in the target document you’ll see that the address in the address box at the top of the window has been appended with ‘#heading=’ and a random-looking variable that acts as the heading’s address. Copy the whole address, complete with the ‘#heading=’ and what follows, and paste it in the Link field in the other document. The link will then take you directly to the heading in the target document.

Google Docs doesn’t provide for bookmarks, but creative use of the six heading levels should cover most uses.

Apple Pages 09, Apple Pages 5, Apple Pages for iCloud Beta

Pages 09 icon Pages for Mac icon Pages for iCloud beta icon

Apple Pages development seems to be travelling in reverse.

  • The old version, Pages 09, can link to webpages and other documents, including their headings.
  • Pages 5 can only link to webpages.
  • Pages for iCloud Beta can’t link to anything.

The latter two aren't complete at the time of writing, but only Pages 09 offers the facilities that students require now. Even if you have upgraded to Pages 5 you might find that you have a folder called iWork 09 in your Applications folder. You’ll find Pages 09 in there.

Bear in mind that files made in 09 can be opened by 5 and the iCloud version, but 09 can’t open the files that those versions make, nor any files originally made in 09 but subsequently opened in 5 or the iCloud version.

To make a hyperlink in Pages 09, open the inspector using the Inspector button in the tool bar. Click on the Links tab (the curved arrow icon) then on Hyperlinks. This is where you choose whether the link will be attached to other text or is to appear as itself. If you're going to attach it to some text, select that text now.
You can make four different types of link: to a web page, an email message, a bookmark in this document, or another Pages document.

  • For a web page, simply paste the address into the URL field.
  • For an email message, supply a recipient and a title for the email. When the link is clicked the reader's email client is opened and a new email is made with that addressee and title.
  • A link to a bookmark requires you to make the bookmark first, selecting Bookmarks instead of Hyperlinks. Any that you've made show in the dropdown list to select. Clicking on the link takes you directly to that point in the document.
  • Linking to another Pages document is a matter of browsing to the document in question. If that document contains bookmarks you are offered them as objects to link to.

Pages hyperlink dialog box

Note the option to Make all hyperlinks inactive. This is what you click if you need to edit the text of a hyperlink. Without it selected, clicking in the link's text activates the link and takes you to that destination. With a tick in this box the links are deactivated allowing you to edit. Cancelling the tick reactivates the links.

In Pages 5 the functionality is reduced, but still useful. To add a link, click on the pilcrow (¶) button and choose Add link. You can link to a web page or set up an email link, as above, but there is no way to link to bookmarks in the present document nor to other documents. If you select Web page you merely have to paste the URL into the URL field. Any text you had selected before adding the link is inserted into the Display field. If you select text and try to add a link but find that the Add link menu item is greyed out it might be because your selection includes a paragraph mark. If you reselect without the paragraph mark, Add link will return.

In Pages 5 when you click on a hypertext link you are not immediately taken to the link's destination. Instead you are given a choice of whether to Edit the link or Go to page.

Page 1 of 2